Any way to use inline fills in SECT_​​FILL&SECT_​​ATRS

Home Forums General discussions Any way to use inline fills in SECT_​FILL&SECT_​ATRS

This topic contains 4 replies, has 2 voices, and was last updated by  Piotr Dobrowolski 5 months ago.

  • Author
    Posts
  • #3995

    Piotr Dobrowolski
    Participant

    I am trying to do a “user” and “library” proof object so I wanted to use inline fill atributes in SECT_ATRS or SECT_FILL
    Looks like the commands do not recognize negative indexes (the inline defined)

    Is there any other way or “the “road is closed”?

    Piotr

  • #4000

    Péter Baksa
    Participant

    You can add a fill type parameter, and the user can select the inline fill there.

    Péter Baksa
    Software Engineer, Library Team
    GRAPHISOFT SE

  • #4014

    Piotr Dobrowolski
    Participant

    I cannot see the inline fill defined in the masterscript in the fill type parameter normally…should I do some values restritcion to the parameter and set it to: values "fill_parameter" RANGE (,0)?

    Piotr

  • #4015

    Péter Baksa
    Participant

    Hi,

    According to this document it should be working, but looks like the inline definition gets written to the attributes only after using it by name in the 2D script, and is not accessible from 3D this way. We will check if this is a bug or some technical limitation.

    You can put the definiton in a MASTER_GDL_….gdl file (plain text file). This way the attribute is created when the library is loaded, and you can use it in all libparts by name.

    Péter Baksa
    Software Engineer, Library Team
    GRAPHISOFT SE

  • #4016

    Piotr Dobrowolski
    Participant

    The trick with MASTER_GDL I know very well…I just wanted to make a fill inside one object and use it in it only ;(
    not messing around with the attributes in the project….

    Seems the fill defined inline works only for 2d script – even if defined in master or 3d script – the negative values of indexes are “invisible” for SECT_FILL and so on….;(

    Piotr

You must be logged in to reply to this topic.