Hotspots in section

Home Forums Problems and solutions in GDL Others Hotspots in section

This topic contains 6 replies, has 2 voices, and was last updated by  Szabadi Gergely 1 year, 7 months ago.

  • Author
    Posts
  • #2426

    Szabadi Gergely
    Participant

    I have the following problem with hotspot: when i create an object with 3d hotspots and 2d hotspots, in the general floorplan the hotspots can be scaled and if I move the object, the scale follows it, but when I am in section view, I can scale the 3d hotspots, but when the object is moved, the scale does’t follow it. What do i do wrong?

    example:

    !3D script
    block 1, 1, 1
    
    for i=1 to 2
    hotspot 0, 0, i-1
    hotspot 0, 1, i-1
    hotspot 1, 0, i-1
    hotspot 1, 1, i-1
    next i
    
    !2D script
    rect2 0, 0, 1, 1
    
    hotspot2 0, 0
    hotspot2 0, 1
    hotspot2 1, 0
    hotspot2 1, 1

    G. Szabadi

  • #2427

    Gergely Fehér
    Keymaster

    You should create editable hotspots for your object. Check it in the reference guide: http://gdl.graphisoft.com/gdl-basics/hotspots-graphical-editing/

    Gergely Fehér
    Team Leader, Library Team
    GRAPHISOFT SE

  • #2429

    Szabadi Gergely
    Participant

    Thank you!

    G. Szabadi

  • #2430

    Szabadi Gergely
    Participant

    Thanks again! When I add flags for the hotspot, in section view the scaling follows the object, BUT If I have an object, where I use macro object more then one, I have problem with the unique flags because they have to be unique, but it is defined the same way.
    Any solution?

    Thx

    G. Szabadi

  • #2431

    Szabadi Gergely
    Participant

    by flags I ment unID

    G. Szabadi

  • #2433

    Gergely Fehér
    Keymaster

    You should add an integer parameter to your macro, for example “hotspotIdStart” and give a proper value (greater then the amount of hotspots placed in the macro) to it when you call the macro.

    Gergely Fehér
    Team Leader, Library Team
    GRAPHISOFT SE

  • #2436

    Szabadi Gergely
    Participant

    Thank you, Gergely!

    G. Szabadi

You must be logged in to reply to this topic.